Repository navigation
build(deps): @types/node 26.6.5 (Node 26 types) - #50
Conversation
devDependencies @types/node ^25.0.9 -> ^26.6.5. yarn.lock (yarn 1.22.22, `yarn install --ignore-scripts`): new entries @types/node@^26.6.5 -> 26.6.5 and undici-types@~8.9.0 -> 8.9.0 only (resolved host set to registry.npmjs.org like the rest of the file). TypeScript stays 5.9.3. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
|
No actionable comments were generated in the recent review.
|
| Layer / File(s) | Summary |
|---|---|
Update Node.js type requirement package.json |
The @types/node development dependency requirement changes from ^25.0.9 to ^26.6.5. |
Priority:
Estimated code review effort: 1 (Trivial) | ~5 minutes
Change: Other
Possibly related PRs
- ever-co/ever-api-starter-kit#21: This PR changes the same
@types/nodedependency entry. - ever-co/ever-api-starter-kit#49: This PR updates the API Docker image to Node.js 26, which is related to the type dependency update.
Suggested reviewers: adkif
Merge Risk: 
Minimal · up to d1313
-
The Node.js type dependency update is mergeable with normal checks.
Pre-merge checks: 
5
-
Full details: Docstring Coverage
-
Explanation
No functions found in the changed files to evaluate docstring coverage. Skipping docstring coverage check. Docstring coverage is scoped to functions touched by this diff. Analyzed 0 functions across 0 files. (1 skipped: 1 unsupported.)
-
Finishing Touches
-
🧪 Generate unit tests (beta)
-
- Commit to this branch
- Create a new PR
-
- Autofix · Keep fixing CodeRabbit findings and required CI, and resolving merge conflicts
Warning
Some tools did not complete. Review the errors below.
🔧 ESLint
-
If the error stems from missing dependencies, add them to the package.json file. For unrecoverable errors (e.g., due to private dependencies), disable the tool in the CodeRabbit configuration.
package.json
-
Oops! Something went wrong! :(
ESLint: 9.39.2
Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath './@typescript-eslint' is not defined by "exports" in /node_modules/eslint-config-prettier/package.json
Referenced from: /.eslintrc.js
at exportsNotFound (node:internal/modules/esm/resolve:315:10)
at packageExportsResolve (node:internal/modules/esm/resolve:663:9)
at resolveExports (node:internal/modules/cjs/loader:754:36)
at Module._findPath (node:internal/modules/cjs/loader:821:31)
at Module._resolveFilename (node:internal/modules/cjs/loader:1557:27)
at wrapResolveFilename (node:internal/modules/cjs/loader:1118:27)
at resolveForCJSWithHooks (node:internal/modules/cjs/loader:1169:12)
at require.resolve (node:internal/modules/helpers:175:31)
at Object.resolve (/node_modules/@eslint/eslintrc/dist/eslintrc.cjs:2447:46)
at ConfigArrayFactory._loadExtendedShareableConfig (/node_modules/@eslint/eslintrc/dist/eslintrc.cjs:3383:33)
(node:2) ESLintRCWarning: You are using an eslintrc configuration file, which is deprecated and support will be removed in v10.0.0. Please migrate to an eslint.config.js file. See https://eslint.org/docs/latest/use/configure/migration-guide for details. An eslintrc configuration file is used because you have the ESLINT_USE_FLAT_CONFIG environment variable set to false. If you want to use an eslint.config.js file, remove the environment variable. If you want to find the location of the eslintrc configuration file, use the --debug flag.
(Usenode --trace-warnings ...to show where the warning was created)
-
Thanks for using CodeRabbit! It's free for OSS, and your support helps us grow. If you like it, consider giving us a shout-out.
A rabbit checks the version line,
New Node types now sit in place.
The package file records the change,
No extra carrots need a chase.
Ears twitch; the update is complete.
Comment @coderabbitai help to get the list of available commands.
There was a problem hiding this comment.
🔵 Needs a closer look
The major typings upgrade needs human confirmation of package artifacts and the reported compiler checks, which could not be independently verified.
No open issues 🎉
What changed in this PR
Updates Node.js type definitions to the Node 26 line to align with the API image described in the PR.
Changes:
- Bumps
@types/nodefrom^25.0.9to^26.6.5. - Adds lockfile entries for
@types/node26.6.5 andundici-types8.9.0, preserving the existing wildcard resolution.
| File | Description |
|---|---|
yarn.lock |
Locks the new type packages while retaining existing transitive resolutions. |
package.json |
Updates the direct Node.js type dependency to ^26.6.5. |
Review effort: Balanced
[Low impact] The PR appears safe to merge; no actionable issue was established. SummaryUpdates
Reviews (1) · Last reviewed commit: "build(deps): @types/node 26.6.5 (Node 26..." · Reviewed by Greptile |
|
NN #18 review: CodeRabbit = no actionable comments (it excludes |
Moves the Node type definitions to the Node 26 line, matching the Node 26.12.1 API image (NN #17: Node and
@types/nodemove together).package.jsondevDependencies@types/node^25.0.9^26.6.5yarn.lock@types/node@^26.6.5^25.0.9)yarn.lockundici-types@~8.9.0packageManagerpin),yarn install --ignore-scripts; nothing else moved (@types/node@*for transitive users stays on 25.0.9). The two newresolvedURLs point atregistry.npmjs.org, like the rest of the file.@types/node26 needs >= 5.6).tsc --noEmit -p tsconfig.jsonand-p tsconfig.build.json: exit 0 with@types/node26.6.5 + TypeScript 5.9.3. The dev image build (push to develop) builds it on Node 26.12.1.DO_ENABLED).Rollback: revert the merge commit.
🤖 Generated with Claude Code